注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

获于耕耘中

一分耕耘,一份收获

 
 
 

日志

 
 

整合一个主图公式:  

2015-12-24 16:55:23|  分类: 通达信主图公式 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

整合一个主图公式:

 

 

DRAWNUMBER(ISLASTBAR ,C,C),COLORWHITE;

N8:=STRCAT(CON2STR(YEAR,0),' 年 ');

Y8:=STRCAT(CON2STR(MONTH,0),' 月 ');

R8:=STRCAT(CON2STR(DAY,0),' 日 ');

MAA5:MA(C,5),COLORFF00FF,LINETHICK2;

MAA10:=MA(C,10){,COLORF96299,LINETHICK2};

MAA30:MA(C,30),COLORRED;

MA3:MA(CLOSE,60),COLORLIBLUE;

KS:IF(MAA10>MAA30,MAA10,MAA30),COLORGREEN,LINETHICK2;

DRAWICON (CROSS(MAA5,KS),LOW-0.55,23);

A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

A4:=SMA(A3,3,1);

A5:=SMA(A4,3,1);

A6:=3*A4-2*A5;

A7:=C-REF(C,1);

A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);

:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));

{DRAWTEXT(FILTER(=1,5),LOW-0.05,'买进'),COLORYELLOW;}

{STICKLINE(,OPEN,CLOSE,2,0),COLORYELLOW;

STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORLIRED;}

开心:=V/REF(V,1)>=2.0;

YES1:=SUMBARS(开心,1);

AA:=STICKLINE(YES1,REF(L,YES1-1)*1.002,REF(L,YES1-1),4,0),COLOR00AAFF,LINETHICK3;

强撑:IF(YES1,REF(L,YES1-1)*1.002,REF(L,YES1-1)),LINETHICK2,COLOR00AAFF;

HH0:=MAX(HHV(H,120),HHV(MA(C,120),120));

LL0:=MIN(LLV(L,120),LLV(MA(C,120),120));

MM0:=CONST((HH0+LL0)*0.5);

T1:=IF(CAPITAL>1 AND GNBLOCK,STRCAT('TDX概念:',GNBLOCK),'');

T2:=IF(CAPITAL>1,EXTERNSTR(0,2),'');

T3:=IF(CAPITAL>1,EXTERNSTR(0,1),'');

T4:=IF(CAPITAL>1,EXTERNSTR(0,3),'');

T5:=IF(CAPITAL>1,STRCAT('TDX行业:',HYBLOCK),'');

T6:=IF(CAPITAL>1,STRCAT('TDX地域:',DYBLOCK),'');

T7:=IF(CAPITAL>1,EXTERNSTR(0,8),'');

X1:=CONST(IF(REF(MA(C,20),130)>MM0,1.00,-0.04));

X2:=CONST(IF(REF(MA(C,20),130)>MM0,-1,1));

S0:=IF(1,X1,DRAWNULL);

S1:=IF(FINDSTR(T1,'TDX概念'),S0+(0.04*X2),S0);

S2:=IF(FINDSTR(T2,'DZH主营'),S1+(0.04*X2),S1);

S3:=IF(FINDSTR(T3,'DZH主题'),S2+(0.04*X2),S2);

S4:=IF(FINDSTR(T4,'TDX主题'),S3+(0.04*X2),S3);

S5:=IF(FINDSTR(T5,'TDX行业'),S4+(0.04*X2),S4);

S6:=IF(FINDSTR(T6,'TDX地域'),S5+(0.04*X2),S5);

S7:=IF(FINDSTR(T7,'年度业绩'),S6+(0.04*X2),S6);

DRAWTEXT_FIX(1,0,S1,0,T1)COLORFF8800;

DRAWTEXT_FIX(1,0,S2,0,T2)COLOR00CC00;

DRAWTEXT_FIX(1,0,S3,0,T3)COLOR3060FF;

DRAWTEXT_FIX(1,0,S4,0,T4)COLORFF88FF;

DRAWTEXT_FIX(1,0,S5,0,T5)COLOR00AAFF;

DRAWTEXT_FIX(1,0,S6,0,T6)COLORFFFFFF;

DRAWTEXT_FIX(1,0,S7,0,T7)COLORFF00FF;

P2:=240;

TC1:=IF(H=HHV(H,P2),C,DRAWNULL);

TC2:=CONST(BARSLAST(TC1=H))+1;

UPPER:=CONST(IF(TC2=1,C,REF(C,TC2-1)));

BC1:=IF(L=LLV(L,P2),C,DRAWNULL);

BC2:=CONST(BARSLAST(BC1=L))+1;

LOWER:=CONST(IF(BC2=1,C,REF(C,BC2-1)));

LP:=CURRBARSCOUNT<=BC2 AND C=LOWER;

HP:=CURRBARSCOUNT<=TC2 AND C=UPPER;

NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));

LR1:=FORCAST(C,NOD+1);

NP:=IF(CURRBARSCOUNT<=MAX(BC2,TC2),CONST(IF(MIN(TC2,BC2)=1,LR1,

REF(LR1,MIN(TC2,BC2)-1))),DRAWNULL),POINTDOT,COLORFF0000;

LR2:=SLOPE(C,NOD+1);

LR3:=CONST(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)));

FP:=NP-LR3*(NOD),POINTDOT,COLORFF0000;

EQU:=(NP+FP)/2,POINTDOT,COLOR0000FF;

AD:=ABS(NP-FP);

DBL:=BARSLAST(BC1!=DRAWNULL)+1;

DBH:=BARSLAST(TC1!=DRAWNULL)+1;

BSP:=IF(BC2>TC2,DBL,DBH)-1;

LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);

AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL);

AT2:=HHV(AT1-LRL,MAX(BC2,TC2));

AT3:=CONST(BARSLAST(AT1-LRL=AT2));

AT4:=CONST(IF(AT3=0,H,REF(H,AT3)));

AT5:=CONST(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)));

ATL:=LRL+AT5;

UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L<LRL,L,LRL);

UT2:=HHV(LRL-UT1,MAX(BC2,TC2));

UT3:=CONST(BARSLAST(LRL-UT1=UT2));

UT4:=CONST(IF(UT3=0,H,REF(H,UT3)));

UT5:=CONST(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)));

UTL:=LRL-UT5;

RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,CONST(REF(ATL,MIN(BC2,TC2)-11)));

RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,CONST(REF(UTL,MIN(BC2,TC2)-11)));

中轨:IF(NP>FP,IF(LRL<=RH,LRL,DRAWNULL),IF(LRL>=RL,LRL,DRAWNULL)),COLORBLUE,LINETHICK1,DOTLINE;

上轨:IF(NP>FP,IF(ATL<=RH,ATL,DRAWNULL),IF(ATL>=RL,ATL,DRAWNULL)),COLORMAGENTA,LINETHICK1,DOTLINE;

下轨:IF(NP>FP,IF(UTL<=RH,UTL,DRAWNULL),IF(UTL>=RL,UTL,DRAWNULL)),COLOR00EE00,LINETHICK1,DOTLINE;

DRAWICON(CROSS(C,上轨),上轨,1);

DRAWICON(CROSS(下轨,C),下轨,2);

DRAWNUMBER(ISLASTBAR,上轨,上轨),COLOR00FFFF,LINETHICK2;

DRAWNUMBER(ISLASTBAR,中轨,中轨),COLORWHITE,LINETHICK2;

DRAWNUMBER(ISLASTBAR,下轨,下轨),COLOR00FF00,LINETHICK2;

ZRS:=CONST(DYNAINFO(3)),NODRAW;

AW1:=5*(EMA(CLOSE,12)-EMA(CLOSE,26))+ZRS,COLORMAGENTA,DOTLINE;

AW2:=EMA(AW1,9),COLORLIBLUE,DOTLINE;

MACDQ:=(AW1-AW2)*2+ZRS;

STICKLINE(AW1>=AW2,ZRS,MACDQ,0,1),COLORRED;

STICKLINE(AW1<AW2,ZRS,MACDQ,0,1),COLORCYAN;

C,COLORWHITE,LINETHICK2;

均价:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK2;

IF(均价<=REF(均价,1),均价,DRAWNULL),COLORBLUE,LINETHICK2;

IF(均价>=REF(均价,1),均价,DRAWNULL),COLORYELLOW,LINETHICK2;

DRAWICON(CROSS(C,均价),均价,13);

JJ:=CLOSE;

J1:=MA(JJ,5);

J2:=MA(JJ,10);

J3:=MA(JJ,20);

J4:=MA(JJ,40);

J5:=MA(JJ,60);

J6:=MA(JJ,120);

J7:=MA(JJ,240);

WXSS:=C>MAX(J1,MAX(J2,MAX(J3,MAX(J5,J6)))) AND (C>O OR C>REF(C,1));

STICKLINE(WXSS AND (NOT(REF(WXSS,1))),O,C,1,0),COLORYELLOW;

STICKLINE(WXSS AND (NOT(REF(WXSS,1))),H,L,0,0),COLORYELLOW;

WXSX:=C<=MIN(J1,MIN(J2,MIN(J3,MIN(J4,MIN(J5,J6))))) AND (C<=O OR C<=REF(C,1));

STICKLINE(WXSX AND (NOT(REF(WXSX,1))),O,C,1,0),COLORBLUE;

STICKLINE(WXSS AND (NOT(REF(WXSS,1))),H,L,0,0),COLORGREEN;

TT1:=C/REF(C,1)>1.095 AND H=C;

TT2:=REF(C,1)/REF(C,2)>1.095 AND H=C;

TT:=TT1 AND TT2;

TT3:=COUNT(TT,10)=1;

N:=BARSLAST(TT);

TT4:=C>REF(C,N) AND V/REF(V,1)>=1.6;

TT5:=COUNT(C<REF(C,N),N-1)>=1;

V5:=EMA(CLOSE,1);

主线:=EMA(V5,5) ;

:=EMA(HHV(主线,5),1);

急进:=EMA(HHV(,17),1);

稳健:=EMA(HHV(急进,17),2);

飞天:EMA(HHV(稳健,17),3),LINETHICK2, COLORWHITE;

短撑:LLV(HIGH,30),LINETHICK2,COLORLIRED;

明涨停:=CLOSE * 1.1,NODRAW;

ST涨停:=CLOSE * 1.05,NODRAW;

1个点:=REF(C,1)*1.01,COLORRED,NODRAW;

VAB0:=531;

VAB1:=1510000;

VAB2:=VAB0 + VAB1;

VAB3:=IF(DATE > VAB2,0,1);

VARA12:=SMA(H,10,9)*VAB3;

VARA13:=SMA(L,10,9)*VAB3;

卖价:=VARA12,COLORFF00FF,NODRAW;

补价:=VARA13,COLORGREEN,NODRAW;

 

顶点:IF(CURRBARSCOUNT<=44, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=44)),1)),DRAWNULL),COLORRED,DOTLINE;

低点:IF(CURRBARSCOUNT<=44, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=44)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;

整合一个主图公式: - 获于耕耘中 - 获于耕耘中

 

  评论这张
 
阅读(37)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017