注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

获于耕耘中

一分耕耘,一份收获

 
 
 

日志

 
 

通达信加密公式破解  

2017-02-10 19:42:18|  分类: 股市学习 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

通达信加密公式破解


鼠标指定你要修改的指标,右击“当前指标”点击“修改指标参数”,就能看到源码。
时间限制是一种加密的方法,其原理是在指标中加入时间函数,把时间设定在一定的使用范围内,当超过设定的时间之后,指标图形中的线条和有关信号消失或失真,造成指标不能继续使用。用时间限制加密的形式有多种,举例子加以说明解除的方法:
看这个副图指标:
Var1:=IF(DATE<=1040701,1,0);
Var2:=DMA(CLOSE,HIGH/MA(LOW,4)/4);
Var3:=DMA(CLOSE,CLOSE/MA(LOW,30)/30);
Var4:=(LOW-Var2)/Var2*100<-5.889;
Var5:=(Var2-Var3)/Var3*100<-15.889;
Var6:=Var4 AND Var5 AND (HIGH-MA(LOW,3))/REF(LOW,2)>-0.059;
Var7:=Var6>0;
Var8:=AMOUNT/VOL/100;
Var9:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarA:=SUM(AMOUNT,13)/Var8/100;
VarB:=DMA(Var9,VOL/VarA);
VarC:=MA(HHV(HIGH,488),18);
VarD:=MA(HHV(HIGH,220),18);
VarE:=MA(HHV(HIGH,98),18);
VarF:=MA(LLV(LOW,488),18);
Var10:=MA(LLV(LOW,220),18);
Var11:=MA(LLV(LOW,98),18);
Var12:=MA((VarF*0.96+Var10*0.96+Var11*0.96+VarC*0.558+VarD*0.558+VarE*0.558)/6,18);
Var13:=MA((VarF*1.25+Var10*1.23+Var11*1.2+VarC*0.55+VarD*0.55+VarE*0.65)/6,18);
Var14:=MA((VarF*1.3+Var10*1.3+Var11*1.3+VarC*0.68+VarD*0.68+VarE*0.68)/6,18);
Var15:=MA((Var12*3+Var13*2+Var14)/6*1.738,18);
Var16:=IF(DATE<=1021231,Var15,Var15*DAY);
Var17:=LOW;
Var18:=REF(LOW,1);
Var19:=SMA(ABS(Var17-Var18),3,1)/SMA(MAX(Var17-Var18,0),3,1)*100;
Var1A:=MA(IF(CLOSE*1.35{<=Var16},Var19*10,Var19/10),3);
Var1B:=LLV(LOW,30);
Var1C:=HHV(Var1A,30);
Var1D:=IF(LOW<=Var1B,(Var1A+Var1C*2)/2,0);
Var1E:=MA(Var1D AND CLOSE<COST(1),3) AND (CLOSE-VarB)/VarB*100<-11;
Var1F:=MA(CLOSE,5);
Var20:=MA(CLOSE,10);
Var21:=MA(CLOSE,20);
Var22:=MA(CLOSE,30);
Var23:=(Var1F+Var20+Var21+Var22)/4;
Var24:=(Var23-REF(Var23,15))/REF(Var23,15)*100;
Var25:=IF(Var24<-10 AND Var24<REF(Var24,1),20,0);
买入: Var7*Var1 AND Var1E*Var1 AND Var25*Var1 AND (CLOSE-OPEN)*Var1>0,linethick2 , colorred;
这个指标中的VAR1、VAR16和买入这3条语句引用了时间限制函数,限制在2004年7月1日前可正常使用,超过这个时间就不能正常使用了。解除时间限制的方法比较简单,只要把VAR1和VAR16这2条语句删除,再把买入语句中的*VA1删除就完全解除了时间限制。
最后再看一个指标:
Var1:=IF(DATE<1030830 AND DATE>900101,1,0);
Var2:=LLV(LOW,10);
Var3:=HHV(HIGH,25);
警戒线:=2.8*Var1;
减仓线:=3.2*Var1;
动力线:=EMA((CLOSE-Var2)/(Var3-Var2)*4,4)*Var1;
VAR4:CROSS(动力线,警戒线);
STICKLINE(VAR4,0,50,4,0);
DRAWICON(CROSS(动力线,警戒线),53,2);
这个指标中的VAR1引用了时间限制函数,限制在2003年8月30日前可正常使用,超过这个时间就不能正常使用了。解除时间限制的方法比较简单,只要把VAR1这条语句删除,再把语句中的*VAR1删除就完全解除了时间限制。
以上例举了2个解除时间限制的方法,试一下吧!
 
把T0002文件夹下PriGS.DAT文件复制后粘贴到你的没时间限制的通达信软件下T0002文件下去复盖没时间限制的PriGS.DAT文件,你要的都有了
 

通达信加密公式破解

 

P1: 2        20    5 
P2: 2        20    4
80, POINTDOT;
20, POINTDOT;
VAR1:=LLV(LOW,P1);
VAR2:=HHV(HIGH,P1);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,P2),COLORFF9900 , ;
D: EMA(0.667*REF(K,1)+0.333*K,2), ,;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1); 
VARD:=EMA(IF(C< EMA(C,250),VARC*1000,VARC*10),3); 
火焰山:EMA(IF(L<=LLV(L,30),VARD/2+HHV(VARD,30),0),3)/618; 
STICKLINE(火焰山>100,0,火焰山*1.2,8,0);
STICKLINE(火焰山>100,0,火焰山,4,1);
金包: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,20,0),COLORYELLOW ,LINETHICK1 ;
VAR3:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;
DRAWTEXT(顶A=50,45,'快逃'),COLOR00FF00;
DRAWTEXT(金包=20,20,'金包'),COLORRED;
 

通达信公式破解方法

 

P1: 2        20    5 
P2: 2        20    4
80, POINTDOT;
20, POINTDOT;
VAR1:=LLV(LOW,P1);
VAR2:=HHV(HIGH,P1);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,P2),COLORFF9900 , ;
D: EMA(0.667*REF(K,1)+0.333*K,2), ,;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1); 
VARD:=EMA(IF(C< EMA(C,250),VARC*1000,VARC*10),3); 
火焰山:EMA(IF(L<=LLV(L,30),VARD/2+HHV(VARD,30),0),3)/618; 
STICKLINE(火焰山>100,0,火焰山*1.2,8,0);
STICKLINE(火焰山>100,0,火焰山,4,1);
金包: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,20,0),COLORYELLOW ,LINETHICK1 ;
VAR3:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;
DRAWTEXT(顶A=50,45,'快逃'),COLOR00FF00;
DRAWTEXT(金包=20,20,'金包'),COLORRED;
 
加密公式的破解,需要较深厚的基本功。
现在有数十种股软,许多种不同股软函数加起来有数千个,编制技法随着的知识更新更是层出不穷。
目前人工破解还是以观其“ 形”,查其“神”,来揣摩其作者的设计思路和编制机理及各种技法运用。
其中最关键的就是要摸清作者的设计思路,也可以说这就是破解中的“纲”!
把握住了这个" 纲“,编制机理及各种技法也就迎刃而解了!
这是一个很苦的差事,需要大量的时间反复去验证,测试。
也是一门专业性很强的差事,需要专业知识和编程技巧和精益求精及刻苦专研的毅力,不是任何人都能做到的。
简单的说:很简单的一条均线,就有许多计算方式,首先你要确定下来加密公式这一条线的是什么类型的?接着你就要做出一条线在股软里对照加密公式来对比,来不断地调整参数来比较两条线的数据每一天的数值是否相符,这是很枯燥费时费事的事情!
这仅仅是简单的一条线而已,其他的也不必说了,其破解费时费事可想而知。
所以,一般价值不是很大的公式是不值得破解的!
1:不是使用Winhex,而是使用Ollydbg来破解.
2:只是用户公式修改密码有效。对于导入密码无效。对于系统公式密码无效,默认的系统公式密码可能是OK_TDX(测试了两个版本,其他的不知道)
不过好像有的不能编辑,不过VOL_TDX等系统的公式好像可以查看和修改。


方法:1:使用Ollydbg,点文件,打开,选择通达信的可执行文件(或者把通达信的执行文件直接拖进Ollydbg的窗口),按F9运行程序。
2:正常使用通达信,进入到K线图后,在k线图(主图或者副图上)点右键,选择指标,然后选择一个加密的公式,点确定。
此时公式应该能正确使用并且在图上显示出来。
3:点右键,选当前指标,选修改指标公式,此时需要输入密码,随便输入几个数,但不要点确定。
4:在Ollydbg的左下角,有一个命令编辑框,输入命令bp _mbscmp,回车,这时断点下好了。
5:点修改密码公式框中的确定按钮,此时中断在_mbscmp中,在右上角的EAX的值就是密码,ECX值是你随便输入的数。
6:找到密码后,点在左上角的红黑色的一行代码,点F2取消断点,再点F9来继续程序执行。可以循环2-6步来得到其他的密码。
7:完成。
  评论这张
 
阅读(9)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017